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Copyright   Consac AS, 2016
Consac AS. — All rights reserved.

None of this documentation can be altered, adapted, or translated into any other languages without the prior written 
permission of the Consac AS. It is prohibited to create any documents, based on the present original materials. 
RenderEM and its logotype, Consac AS and its logotype are the trademarks of Consac AS.  
Microsoft Windows, Microsoft Windows NT, Microsoft Windows 95/98, Microsoft Excel, Microsoft Access are the 
registered trademarks of the Microsoft Corporation. MS-DOS is the registered trademark of the Microsoft 
Corporation. Pentium and Pentium Pro are the registered trademarks of the Intel Company. Adobe Acrobat Reader 
is the registered trademark of Adobe Systems Incorporated. 
Other program and equipment names are the registered trademarks of the corresponding companies. Software 
package RenderEM, described in the present guide, shall be distributed in accordance with the terms of the License 
Agreement and cannot be used, transferred or sold under any other conditions, but these of the clearly specified 
in the following Agreement.  
License Agreement  
Object: Software package RenderEM, comprising programs and documentation (thereafter package). Consac AS 
from one party and the Principal from the other party agreed as the follows: 
Consac AS transfers the Principal a non-exclusive License to use the Package (thereafter License), supplied under 
this Agreement according to the conditions specified bellow. Should the Principal is not contented with the terms 
of the Agreement and/or the Package supplied, he can within 30 days return Consac AS all the transferred 
programs and documentation under the Agreement, Consac AS shall make 100% refund of the amount paid for 
the package.  
License   
 Under this License the Principal may use the programs on one computer only. To use the programs on several 

working places, the Principal shall obtain a corresponding number of paid Licenses.  
 The Principal is entitled to make one archive copy of these programs, which automatically becomes Consac 

AS property and falls under this Agreement.  
 The documentation is not subject to copy and distribution.   
 The Principal shall prevent the obtained Consac AS Package from being used, copied or distributed without 

authorization.  
 This License is valid from the date of the Principal’s obtaining Consac AS Package to its termination. Should 

The Principal break any terms of the License; the latter is automatically no longer valid without Consac AS’ 
notice.  

 All the rights for the name, contents, and appearance of the package shall be the exclusive property of Consac 
AS.  

 The present version and all the following Software versions shall fall under this License.   
Warranty   

 Consac AS warrants that the Software will be free from defects at delivery and for a period of ninety (90) 
days of normal use from the date of the original purchase. Should any defects arisen through the Principal 
fault are detected Consac AS shall replace the defected materials.  

 Consac AS has no warrant responsibility for application and application results of this Package and other 
materials, linked with it, in terms of accuracy, correctness, reliability, etc.  

 Consac AS is not responsible for any damage, directly or indirectly linked with the use of, misuse of, or 
impossibility to apply this Software.  

 No other information, except for the present License, obtained by the Principal shall cause any Consac 
AS warrant responsibility.  

Modifications in the programs and new versions   
The Principal can fill out and forward to Consac AS the User’s Registration Card in order to have a possibility of 
getting the entire supplement, the software new copies on preferential terms and notice of errors correction. 
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Chapter 1 – INTRODUCTION 

Welcome to RenderEM!

RenderEM is designed for enhancing scanned raster images as well as manual and batch 
processing and indexing of scanned images.

Supported Formats

RenderEM allows for work with monochrome and color raster images in the following formats: 
BMP, JPG, JPEG, PNG, PDF (raster) and TIF etc.
RenderEM provides the ability to tune saving settings for several formats as well as to create 
a custom format based on the existing ones properties of some set a custom format.

Features
 A wide range of tools: 
 Mirroring 
 Rotating at 90,180 and 270 degrees, custom rotation  
 Resizing 
 Cropping 
 Automatic de-skewing 
 Four-point correction (Rubber sheeting) Fitting image to closest paper 
 Speckle and Hole Remover Separation by size 
 Smoothing, Thickening and thinning 
 Inversion, Binarization, Image Filtering 
 Multi-page TIFF/PDF support
 Image Stitching 
 Wide range of Image Editing (cut, copy, paste, Buffer Management, Color Tone) tools
 Wide range of color filters and processing tools 
 Batch processing  
 Friendly interface 
 Layout Customization and theme set-up
 Horizontal & Vertical rulers
 Making multi-page Tiff files from singular images and vice versa

 

System Requirement
 OS: Windows 7 onwards.  
 Free disk space: 30 Mb 

RenderEM Installation
 To install RenderEM: 
 Run the RenderEM.exe file from root folder.   
 Follow the instruction to install RenderEM. 
 After Installation, Run the Configuration wizard to ask for license. 
 The Configuration wizard will open.  
 Fill up the form to generate the .cnf file. This file holds all your registration data. 
 Send your registration data via e-mail at license@consac.com, or use the send mail 

option from the wizard. Alternatively, you can get your license directly from our online 
license server by clicking Get License button. Your system must be connected to the 
internet in order to get the license directly from our server. 

mailto:getlicense@consac.com
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Setup the license. 

 If you have requested the license offline, simply browse the license file (*.lic) from your 
computer upon receiving the same. The Configuration Wizard will setup the license for 
you. In case of online activation, the license is already setup when you request it. 

 Alternatively, when you have the license, simply run the RenderEM.exe for the first 
time. If there is no license, it will prompt you to add license for the product 

 Select the license file from your computer like the screenshot below.  
 RenderEM will start working. 

 
Uninstalling RenderEM 

 To uninstall RenderEM you should use the standard procedure for uninstalling all 
Microsoft Windows applications. RenderEM will be completely removed from the 
computer. Any files or templates created by the user will not be removed. 

 Click Start, Settings and open the Control Panel.  
 Choose Add/Remove Programs.  
 Choose RenderEM from the list.  
 Click on the Remove button.  
 Follow instructions on the screen.  
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Chapter 2 – RenderEM Basics  
 

This chapter helps you to familiarize yourself with the main screen components of RenderEM 
βeta and teaches you a few basic skills you will use each time you work with the program.

Running RenderEM
Before you run RenderEM for the first time, install it on your hard disk.

To start RenderEM
 On the taskbar, choose Start, and then click on Programs.  
 Click on RenderEM, then from the displayed folder click RenderEM.  

RenderEM Window 

 

This is a screenshot of RenderEM Version 2.0. Each of the toolbars and window elements are 
described in the following paragraphs. 

Window Ribbon Tab
There are the six RenderEM toolbars: File, Edit, View, Image, Color and Tools. Each of the 
RenderEM toolbar buttons is briefly described below.

File toolbar 
 Open - Opens an existing image. 
 Save - Saves the current image. 
 Save As - Saves the current image to another file. 
 Print - Prints the current image. 
 Print Options - Setting print options. 
 Help – Opens the User’s Guide. 
 Close - Closes the current image file. 
 Exit - Exits RenderEM. 
 List of Recent Items – Lists recently opened images. 
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 List of Pinned Items – A list of Images can be pinned here as favorites. 

Edit toolbar 
 Paste - Pastes the clipboard contents to the image.  

 Paste to Position - Pastes the clipboard contents to the selected position. 
 Paste Mode Inverted - Pastes the clipboard item in its inverted form. 
 Paste Mode Original - Pastes the original clipboard item. 
 Merge to Image - Click on Merge to image to permanently merge the clipboard item 

into the parent image in the desired position. Alternatively, click on the parent image 
outside the pasted clipboard item so as to paste the same on the parent image. 

 Buffer Manager – Opens up the Buffer Manager Dialog Box   
 Copy - Copies Work Area contents to clipboard. 
 Cut - Cuts Work Area contents to clipboard.  
 Erase - Erases the Work Area contents from the image. 
 Undo - Reverses the last action. 
 Redo - Returns the changes reversed with Undo.  
 Set Work Area - Sets Work Area to process a part of the image. 
 Reset Work Area - Resets Work Area to process the entire image.  
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View toolbar 

 Best Fit - Displays a view of the entire raster image.  
 Zoom In - Increases the display magnification x 2  
 Zoom out - Reduces the display magnification by half.  
 Zoom 1:1 - Sets zoom level so 1 screen pixel corresponds to 1 image dot. 
 Pan - Scrolls the image by clicking and dragging with the mouse. 
 Zoom By Height – Sets the document Height to the screen size. 
 Zoom By Width - Sets the document Width to the screen size. 
 Zoom By Rectangle - gives the user an option to zoom a rectangular portion of an 

image so as to make it fit best within the View-Port (Canvas). 
 Magnifier - tool to view a magnified portion of an image 
 Default Themes 
 Layout Customization 

Color Toolbar 

 Brightness/Contrast tuning 
 Hue Saturation Luminosity 
 Color Equalizer 
 Color Separation  
 Color Reduction 
 Binarization 
 Unsharp Mask 
 Gamma Correction 
 Inversion 
 Color Filters 
 Blur 
 Adaptive Blur  
 Color Filters 
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Image Menu 

 Crop By 
o Rectangle 
o Black 
o Frame 
o Work Area 
o Paper 

 Speckle Remover 
 Hole Remover 
 Thickening 
 Thinning 
 Smoothen 
 Flip 
 Mirror 
 Rotate 
 4 Point Correction 
 Resize Resample 
 Deskew By 

o Manual 
o Auto 

Tools Menu 

 Paint Tool.  
 Image manager – controls multi-paging  
 Opens the Script Studio dialog box  
 Runs Batch processing  
 Opens Virtual Scanner facility. 
 Extract singular page from Multi-page Tiff file 
 Multi-page Tiff File maker 
 Image Stitching 

Status bar 
The Status Bar displays information about the cursor position, the resolution and size of the 
current image. 
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Preview Window 
In some RenderEM dialog boxes there is a preview window, where you can observe the result 
of an operation on a selected image part while tuning its parameters. 

 
The image part displayed in the left pane of the dialog is called a preview area. Also, there are 
the following controls: 
 

 Zoom in. Doubles a preview scale in the preview window. 

 Zoom out. Reduces a preview scale by half in the preview window. 

 Zoom 1:1. Displays an image in the preview window 1:1 so that 1 dot in the preview 
window corresponds to 1 dot of an image. 

 Show/Hide Layer. Turns on/off the viewing of results in the preview window. You can 
change the position of a preview area using the mouse. 

 
Color Themes and Layout 
Customization of Color themes is possible using RenderEM. Seven pre-defined color-themes 
have been included in RenderEM. These are: 

 Slate 
 Brick 
 Olive 
 Cookie 
 Sky 
 Cloud and 
 Cinder 

In order to customize layout as per pre-defined Color-modes, first ensure there is no file open. 
Then click on Views. Several pre-defined layouts are available to choose as shown in the 
picture below: 
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Click on any of the seven pre-defined layouts to change the color theme. 

Customized Color Themes 
Besides choosing from the default layouts, a user also has the option to define his/her own 
color themes and store the same as a template or as default. In order to do the same click on 

‘Customize Color Layout’ Ribbon Button  from the View tab after closing the current file 
(if any). This will open a Customize Color Layout dialog box as below: 

Choose the desired colors from the color picker buttons for the respective sections. Once 
chosen, the changes will reflect in the layout preview shown on the left-hand side of the dialog 
box. After choosing the desired colors click on OK. The color scheme would however not 
reflect immediately after clicking OK. In order to view the changes click on the Refresh Ribbon 

Button  just besides the Customize Color Layout Ribbon Button.  

 Three separate buttons are also provided in the Customize Color Layout dialog box: 

 Save Button  to save the layout as a separate template 

 Load Template Button  to load a Color layout template file (*.ltf) from the saved 
templates. 

 Save as Default Button to make a Default Template which would be stored and 
would open up as default. 

Please remember, in order for any color layout changes through ‘Customize color Layout’ 
option to show effect, the user would need to click the refresh button. 

Additionally, any of the pre-defined layouts can also be made to act as a Default Template. 
Simply click on the desired template from the Seven pre-defined set, then open the Customize 
Color Layout dialog box and click on ‘Save as Default’  button. 

  



 
 

12 
 

RenderEM User Guide 

Using Dialog Boxes 
Some RenderEM commands invoke dialog boxes. Dialog boxes contain a number of standard 
controls. The following sections briefly describe these controls. 

Apply button 
Performs the current operation using the parameters you’ve specified, without closing the 
dialog box. 

OK button 
Performs the current operation with the parameters you’ve specified, and closes the dialog 
box. 

Close button 
Closes the dialog box and stores the parameters you’ve specified. The next time the dialog 
box is opened, the last specified parameters will be remembered. 

Cancel button 
Closes the dialog box without saving any changes. 

Help button 
Opens the User’s guide. If the system has Adobe Acrobat Reader installed, the particular page 
where the section is discussed, is opened.  
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Chapter 3 – MANUAL IMAGE PROCESSING
 
Opening and Scanning Image Files

You use the Open command to load existing images of all file types in RenderEM. 
To open a file
Choose Open from the File menu or choose button from the File toolbar. The Open dialog box 
appears. 

 
 Select the name of the file you want to open.  
 Choose Open and the selected file will be loaded. 

  
Virtual Scanner

Using Virtual Scanner you can process images obtained from sources other than scanners, 
for example from video cameras or engineering systems that use scanner-like devices for 
batch input, but do not provide a scanner interface.  
Processing involves applying commands from script files and post processing to distinguish 
processed files from new ones. The path to the folder containing the image files can be 
rescanned at set intervals to retrieve any new files.  
Using this option means that scanning can be performed in the background in a continuous 
loop. 
 
To activate Virtual Scanner

 Choose Virtual Scanner from the Tools menu.  
 In the ‘Path to Scan’ entry select the folder where the source image files reside, and in 

the Script file entry, select the script file containing the required batch of processing 
commands.  

 Select the Post Process option – this is the action to be applied to each source image 
after the batch has been processed.  

 Select Scan interval.   
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 Press Start. 

Virtual Scanner revisits the Path to Scan at each Scan interval and applies the Script file to 
every new source image found that has not previously been marked as processed. Processed 
files can be moved, deleted or marked as processed. 
 
The lower part of the Virtual Scanner dialog box reflects the progress of the processing 
operation. 
 

 Press Stop to terminate the scanning loop.  
 Press Clear Log to begin a new log.  
 Press Start to activate Virtual Scanner again or Close to stop all activities.  

 

Controlling the Display 

Scrolling 
The program window contains horizontal and vertical scrollbars. You can scroll up and down, 
left and right across the whole screen by pressing the scrollbar arrows. 

Panning 
You can use the Pan command from the View menu to move the image in the application 

window without changing the view magnification. To pan the image, click the Pan icon  
button in the View menu. Move the mouse cursor over the image and press the left mouse 
button. Drag the mouse while holding down the left mouse button. The image will move in the 
same direction as the cursor. Release the mouse button to stop panning. To exit panning, click 

 again. 

Zooming 
The most common way to change views is to use one of the many zoom commands, which 
will either increase or decrease the size of the image displayed in the graphics area. Zooming 
does not change the absolute size of the image. It changes the view size within the graphic 
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area. RenderEM offers several ways to change the view, including drawing a zoom window, 
zooming in and out, and displaying the entire image. 

Click  or  from the View Menu or use a mouse wheel to zoom in or out incrementally. 

To zoom to the image extents choose Zoom All or click. 

The Zoom 1:1 command displays an image so 1 screen pixel reflects 1 image dot. To zoom 

1:1 choose click  from the View toolbar. 

Zoom By Rectangle 
Zoom by Rectangle gives the user an option to zoom to a particular rectangular portion of an 
image so as to make it fit best within the View-Port (Canvas).  

In order to zoom-in to a rectangular area within the picture, click on  and then draw a 
rectangle in the desired portion of the image with the help of the mouse left button (click-drag-
release). As soon as the mouse button is released, the chosen area would get zoomed 
optimally to fit within the canvas. 

  

In case after selecting the Zoom by Rectangle option, the user wants to abort the process, 
simply press the esc button. 

Magnifier 
This is another tool to view a magnified portion of an image. Click on the Magnifier Ribbon 

Button  to open a rectangular Magnifying glass in the middle of the View-port. This 
magnifier can be moved around freely by Click-and-dragging the mouse over the magnifier. 
The magnification by default is set to normal. Simply use the mouse–wheel to zoom-in 
(magnify) or zoom-out (de-magnify) as per requirement. 
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In order to get rid of the magnifier, click once again on the Magnifier Ribbon Button. 

 
Rulers (Horizontal & Vertical) 

RenderEM is provided with a pair of rulers to measure the physical size of an image both along 
the horizontal (width-wise) and vertical (height-wise) axes. The origin points of the rulers are 
marked by the top–left position of the image. With the change in the offset position of the 
image with respect to the view-port (when the image is translated or scaled), the origin 
(marked by 0) also gets shifted. Likewise the apparent ruler scale also changes by scaling the 
image through zooming procedures. The actual physical size of the image shows when the 
image is zoomed at its original size (1:1) and the scale units (either inch or centimeter) gets 
its actual physical dimension. 
 
In the intersection point of the 2 rulers, there is a button which acts as a unit conversion toggle 
key. By default, the scale units are marked in ‘inches’ and the button shows the letter ’I’; after 
clicking on the button, the unit of measurement gets changed to ‘centimeter’ and the button 
shows “C” and vice versa. 
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Image Manager 
Image Manager is a tool to control pages in multipage TIFF files and images that become 
separated into layers as a result of a Binarization operation. 

Through the Image Manager dialog you can add, rearrange or delete layers, control visibility 
of layers and save selected layers to a separate image file. Only one of the layers is visible at 

any one time. 

To open the Image Manager choose Image Manager from the Tools menu. 

The left pane displays information about the layers (pages), their type, size and resolution. 
The preview pane on the right is equipped with zoom buttons described in the previous 
section. 

The Image Manager also has the following buttons: 

 

Fetch Original Image – Fetches the original image from which the binary images 
are created. 

 
Save - Saves the selected layer to a separate file. 

 
Delete - Deletes the selected layer. 

 

Previous - Moves the selected layer or page up a level. This allows you to 
rearrange the pages in a multipage TIFF prior to saving. 

 

Next - Moves the selected layer or page down a level. This allows you to rearrange 
the pages in a multipage TIFF prior to saving. 

 

Buffer Manager 
Buffer Manager is used to modify, refine a buffered Image by cutting an irregular portion from 
the main rectangular Buffer and pasting the resultant into the host image. 

In order to use the Buffer Manager, the first pre-requisite is to ensure a portion/or whole of an 
image is actually copied in the buffer. This can be done by copying /cutting a selected portion 
of an image (set by work area) or the whole image as such. Now click on Edit>Paste>Buffer 
Manager as shown below. 
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This would open up a new Dialog Box with the Buffered Image within the preview canvas. Cut 

an irregular polygonal portion as desired from the Buffer using the Scissors button.  Click 
on the ‘Scissors’ button and then define the object boundary through mouse clicks. Continue 
doing it along the border-side of the object to create a red polyline.  The final node can be 
defined by right-clicking the mouse, which would then carve out a proper polygon as shown 
below.  A set of radio buttons are provided; these will either set the background (beyond the 
polygon area) as transparent or the foreground (the polygon area) as transparent. The 
resultant image is shown below:  
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Now this image can be pasted on any host image. Additionally, the image can be scaled and 
resized prior to pasting using the mouse-wheel on any host image. 

 

Though it is not possible to paste a colored image to a monochrome image, the opposite can 
be done. In that case the monochromatic image (1Bpp format – Black-white buffer) can be 

converted into colored format using  button prior to pasting. 

Paste Option: 

A Buffered image (image or portion of the image copied in the Buffer) can be pasted with a 
plethora of available options. It can be scaled or rotated (on XY plane) merely with the 
mouse prior to pasting on the host image. After a buffered image (copied and/or modified in 
Buffer Manager or Color Tone Changer) is pasted on the host image, it still remains a 
separate image unless clicked outside or merged into the image using the merge button. 
Prior to merging, it can be panned (moved from one location to another by the mouse), 
rescaled and rotated easily by the mouse. In order to do so, right click on the pasted image 
to get a list of options as shown below:    
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Color Tone Changer: 
 
In a layman’s term, hue can be defined as a pure color i.e. a color without any tint or shades.  
By adding up white or black pigment, we get an array of colors that share the same Hue. 
Technically, Hue is one of the main components of a color. Hue along with Saturation and 
Luminosity can define a unique color in the HSV spectrum. In RenderEM it is possible to 
change a selected hue in an image and replace it with a different hue. The other 
components (Saturation & Luminosity) of the transformed pixels remains unchanged. This 
capability has a huge application in industrial designing as well as in interior/exterior paint-
work industry.  

To change the hue of selected portion of an image 
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 Copy the image/portion of the image in which you wish to change a particular hue. 
The copied portion becomes the Buffer Image. 

 Click the paste dropdown  and from there select Color Tone Changer… 

 

 A hue converter dialog box will appear on the screen. 
 

 
 Hue Converter 

   Original color- pick the color you want to replace. 

   Replaced color- Pick color from picture which you want to replace the 
original color with. 

   Pick color from color canvas- Pick color from a palate, chose your desire 
shade. 

OK/Cancel    Click ok to do the action or cancel to abort the changes. 

 

 
Basic Manipulations 
The following section describes those commands that can be applied to improve the quality of 
an image. 
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Rotating Images 
The Rotate command rotates the image contents around its center point by the angle you 
choose. 

To rotate an image using a preset rotation angle choose ‘Rotate’ button  from the Image 

Ribbon; then choose a preset angle from the dialog box that appears hence forth:  Button 

(to rotate by 90 counter clockwise),  Button (to rotate 180 degree) , or  Button (to rotate 
by 90 clock-wise). You can also specify a custom angle by dragging the circumferential circular 

red dot to your desired position or choose  button to draw a straight line (using mouse) on 
the image to depict the angle that it creates with the X-axis. 

Mirroring Images 
The Mirror command under the Image menu flips the image contents horizontally or vertically. 

To mirror an image contents choose Mirror from the Image menu then choose by axis X 
(Horizontally) or by axis Y (Vertically). 

De-skewing Images 
This function lets you correct small skew errors that frequently occur during scanning. De-
skewing rotates the whole image around its center point to align it vertically or horizontally. 

To de-skew an image, choose Deskew from the Image menu. You have two options under the 
Deskew menu: Auto and Manual. 

To de-skew raster images manually 
1. Run the operation by choosing Deskew by Manual from the Image menu. 

The following dialog box is displayed: 

 Deskew by Line - Type the skew angle value in Angle Textbox or click the  angle-
measuring button then click-hold-and-drag the mouse to draw a line on the image; the 
angle that the line makes with the horizontal axis defines the de-skew angle. The 
measured value is automatically entered the in Angle box. 

 Deskew by Touch – Click on the Deskew by Touch Button  and then click on any 
black line within the image that is supposed to be horizontal with the de-skewed image. 
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The software immediately recognizes the skew angle of the image and the measured 
angle is automatically pre-populated in the Angle Box.  

To de-skew raster images automatically 
1. Run the operation by choosing Deskew > Auto from the Image menu. 

If RenderEM is able to estimate the rotation angle, the raster image will be de-skewed. 
Otherwise, use the manual de-skewing procedure. 

Cropping Images 
You can crop an image using either a manual procedure (specify a work area), or an automatic 
procedure that detects the image margins by a first black pixel or by a bounding frame. 

To achieve the best cropping results you should deskew the image before you apply the crop 
command. 

From the Image menu choose the specific command you want to apply (see below): 

 
Crop by Rectangle - Crops an image by the rectangle specified manually by the 
user on the image.  

 
Crop by Black - Crops the blank margins of the image by a first black pixel. 

 
Crop by Frame - Crops an image by a bounding frame. 

 
Crop by Work Area - Crops an image by the work area specified in the Edit menu. 

 
Crop by Paper - Crops an image to a standard paper format specified or defined 
automatically.  

To crop paper to a standard size 
The Crop by Paper command allows you to fit an image on to the closest paper format. If the 
chosen paper format is smaller than the image, the part of the image outside the edge of the 
paper will be lost. 

All of the Crop buttons are located on the Image Ribbon menu bar. 

 Choose Image > Crop by Paper Size on the Ribbon Menu. The following dialog box 
appears: 
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 Select a paper format from the list (press the button  to automatically find the 
closest paper format to your image based on your printer) and set the image 
orientation.  

 Press OK. A frame representing the specified paper size appears over your image. 
Drag the frame to the desired position and click (or press ENTER) to confirm. Pressing 
ESC cancels the operation; you can also undo it. 

De-speckling Images 
These filters are applied to the entire image. If you wish to apply filtration to only a part of the 
image use the Set Work Area command from the Edit menu. 

Speckle Remover 
The Speckle Remover filter removes raster objects (isolated clusters of pixels) whose size is 
smaller than the specified value. This filter can automatically estimate the size of the spots in 
the image. 

  

  

To use the Speckle Remover filter 
 Choose Speckle Remover from the Image Ribbon menu. The Speckle Remover dialog 

box appears. 

 

 Specify the maximum size of raster objects to be removed, either in the current units 
(left box) or in dots (right box). Alternatively you can set the Auto Estimating option so 
that the filter automatically estimates the raster speckle size before filtration.  

Before Speckle Remover After Speckle Remover 
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 To specify the raster object size on the screen, click this button and pick a point inside 
the object, or 

 Click this button and then click-hold-drag and release your mouse on the canvas to 
create a line segment. The program will specify a speckle size equal to the number of 
pixels/dots contained in the line segment [calculated based on the image resolution 
(DPI)]. 

 Click Apply.  

Hole Remover 
The Hole Remover filter fills holes in raster objects. The filter removes holes that have a size 
smaller than the specified value. This filter can automatically estimate the size of the holes. 
 

 
To use the Hole Remover filter 

1. Choose Hole Remover  from the Image Tab. The Hole Remover dialog box 
appears. 
 

 
1. Specify the maximum size of raster holes to be removed in the current units (left box) 

or in dots (right box) or alternatively set the Auto Estimating option so that the filter 
automatically estimates the raster hole size before filtration. 

To specify the raster object size on the screen, click this button  and pick a point 

inside the object, or Click this button  and draw a line segment on the screen using 
a mouse. The program will specify a speckle size equal to the number of pixels that 
can be contained within the line segment given the resolution (Dpi) of the image. 
 

2. Click on Apply 
 
You can also specify a rectangular area within the image where the hole removal needs 
to be carried on. In that case the Hole Remover tool will only act for all speckle size within 
the area. However, if the speckle within the area is big enough to pass beyond the 
rectangular region, that would also get removed. 
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Inversion 
The Inversion filter inverts raster dots so that black dots become white and white dots, black. 
The following illustration shows the results of inversion filtration. 

  
Original Image Fragment After Inversion 

To use the Inversion filter, choose Inversion from the Image menu. 

Smoothing
The Smoothing filter smoothens the contours of raster objects. 

This filter works in two steps. During the first step, the Smoothing filter converts the 
monochrome image to gray-scale and applies a Medianing operation to it. This operation 
searches the radius of a selection of pixels and replaces the center pixel with the median 
brightness value of those pixels. This produces the effect that may be described as blurring of 
the contours of raster objects. Increasing the Medianing value makes the blurring wider. 

  
Original Image Fragment After Smoothing 

During the second step, the filter converts those pixels that have a brightness values less than 
the Threshold parameter value to black. The wide black lines on the next picture show the 
resulting boundaries. Pixels inside those boundaries become black, the outer pixels become 
white. Increasing the Threshold value thickens objects, while decreasing the value makes 
them thinner.  

 
The first stage – Medianing The second stage - Binarization 

After these two operations are performed the image is converted back to monochrome. 
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To use the Smoothing filter 

 Choose Smoothing from the Image menu. The Smoothing dialog box appears. 

 Specify the Medianing value. This value determines the degree of medianing of the 
contour pixels.  

 Specify the Threshold value. This value determines the degree to which raster objects 
thickening. A higher value increases the degree of smoothing but raster lines will also 
become thicker. 

 Choose OK. 

Thickening 
The Thickening filter makes raster objects thicker by the specified number of pixels. You can 
choose a combination of thickening directions. 

The following figure below shows the Thickening filtration effect if all directions are chosen. 
The left picture shows the original raster image, and the picture on the right shows the result 
of Thickening filtration after three passes. 

 

    
Steps of Thickening in virtual direction 
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To thicken an object 
 Choose Thickening from the Image menu or press this but-ton on the Image toolbar.  
 Select the desired thickening direction: Horizontal – by horizontal, Vertical – by vertical, 

All – horizontal, vertical and diagonal.  
 Choose Apply. 

Thinning 
The Thinning filter makes raster fragments thinner by the specified number of pixels in the 
specified directions – horizontal, vertical, and diagonal. This filter has a supplementary 
parameter that allows you to thin raster objects to their skeleton (only the pixels in the middle 
are left). 

 

 

 

 

To thin an image 
 Choose Thinning from the Image menu or press this button on the Image toolbar. 

 Specify the desired number of thinning filtration passes. or -  
 Select thin image up to skeleton to convert all the objects to one-pixel lines. 
 Choose Apply. 
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Four-Point Correction 
This basic kind of image four-point correction (rubber-sheeting) is a quick and simple way of 
aligning mainly technical drawings. This procedure is based upon the assumption that both 
the outside image frame and the image contents are distorted in the same way. 

To perform this procedure, you need to specify the current locations of the frame corner points 
on the image and the frame size – its width and height. If the image contains a drawing frame, 
RenderEM can estimate this frame location and corner positions automatically. You can check 
the specified frames visually. The red polyline is the source area on the image and the blue 
rectangle is the destination area. RenderEM will then try to find the nearest paper size from 
the Standard Papers list and if required, correct the image by the found paper size. You can 
also choose the paper size manually. 

As a result of correction, the image part enclosed by the specified frame is transformed so that 
the frame corner points match the corners of the rectangular frame specified, with its sides 
parallel to the X and Y axes. 

To correct an image by 4 points 
 From the Tools menu, choose 4-point Correction. The above dialog box appears. 
 In the dialog, press the Find frame button. If RenderEM is able to find the drawing 

frame you will see a color polygon overlaid on the drawing frame. If the polygon is 
incorrectly positioned you should specify these points manually.  

 To specify the frame corners manually you should press the Measure button and click 
the frame corners on the image. You can specify these points in an arbitrary order 
because the program always sorts them so they form a frame without any 
intersections. If you make a mistake, repeat this step.  

 Enter the correct frame dimensions in the Width and Height fields. This can be done 
manually, or you can apply the Find Closest Paper command. If you want to use the 
internal drawing frame size, you have to turn on this checkbox. The internal page frame 
for a particular page format is set in the Preferences dialog.  

 Click OK to run four-point correction. 

Fit Image to Closest Paper 
To fit an image to the closest paper size RenderEM offers two different commands in Image 
menu: 
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Fit to Closest Paper – RenderEM will automatically select the nearest paper size from the 
Papers list, thus enlarging the image. To modify the contents of the Papers list choose 
Preferences from the Tools menu. 

Resize to Closest Paper – RenderEM will adjust the nearest paper size in the best possible 
way. In some cases it may entail cropping a bit of the image margins. 

Image Scaling 
The Resample command proportionally scales an image or changes the resolution of an 
image. You can either change DPI with the image size in pixels fixed or change the image 
size in pixels. 

Start the Resample command from the Image menu or the toolbar. The Resample dialog box 

appears. 

 Choose measurement units from the combo-box: pixels, centimeters, inches, 
millimeters, or points. 

 If you only wish to change the original image size, select the Fixed Size in Pixels 
checkbox. In this case the image dimensions in pixels will not be changed, and you 
can only change image dimensions in millimeters, inches, etc. by changing the 
resolution value.  

 Clear the Fixed Size in Pixels checkbox to change the image dimensions by adding or 
subtracting pixels.  

 Change the image dimensions. Enter values in Width and Height or change the scale 
in Scale. 

 Enter a resolution value in dots per inch (dpi). 

Note: If the measurement units are set in pixels and Fixed Size in Pixels checkbox is on, 
entering a new resolution does not affect the height or width values. 

 Click OK 
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Processing Image Parts 
To work only with a part of the currently loaded image you have to set a rectangular work area 
by using the Set Work Area command from the Edit menu. You can apply the following 
operations to an image part: 

 Copy image part to clipboard  
 Cut image part to clipboard  
 Pastes image part from clipboard  
 Erase image part contents  
 Rotate by 90/180/270  
 Mirror by X/ by Y  
 Crop by Work Area  
 Deskew  
 4-point correction  
 Inversion  
 Speckle Remover  
 Smoothing 
 Print 

To work with an entire image choose Reset Work Area from the Edit menu. 

To paste the clipboard contents to the image origin choose the Paste command from the Edit 
menu. To paste the clipboard contents to a specified position choose the “Paste To” Position 
command and specify the position on the image. 

Undoing and Redoing Changes 
RenderEM always remembers the previous state of your image. If you make a mistake or do 
not like the effect you have created, the Undo command can reverse the last action. 

To cancel the most recent action 
From the Edit menu, choose Undo. 

Cancelling the last action with the Undo command can be redone with the Redo command 
(must be done immediately after undoing). 

To return the image changes cancelled with Undo 
From the Edit menu, choose Redo. 

Saving Images 
RenderEM may save images to files using a wide range of raster file formats. The Save 
command saves the image in the current file format. To save an image, choose Save form the 
File menu. 

The Save As command displays a dialog box that allows you to specify a new filename, file 
type and location. 

To save an image to a new file 
 From the File menu, choose Save As.  
 Select the required raster file format in the Save as Type list box.  
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 When the Options button is enabled, you can choose optional features for the selected 
file format. 

Printing Images 
For any given image view, you can print the entire image or a selected rectangular area. You 
can scale your print output and specify the number of copies to print. The print area can be 
positioned on the paper by defining print margins and alignment. While printing is being 
prepared, the current print area and its location on the paper are displayed on the screen. For 
the multipage type of output, you are shown how the image parts are distributed across the 
individual pages. 

When printing images of different sizes in batch, RenderEM offers the Nesting option. It 
provides the optimal images arrangement, thus saving paper. 

To print images you need to: 

 Install a printer;  
 Set the print options;  
 Run printing. 

Installing a Printer 
A printer must be installed before it can be used to print from RenderEM. Printers can be 
installed using Printers from the Microsoft Windows Control Panel. To start the Printers dialog 
you should press the Start button on the taskbar and choose Settings/ Printers or open Printers 
from the Control Panel. For more information on installing printers, see the Windows 
documentation. With several printers installed, you can print RenderEM images to any 
Windows printer device. 

Settings Print Options 
From the File menu choose Print Options. In the Print Options dialog: 

 Select the printer device from the Printer section.  
 Press the Setup button to change the current printer properties. Set new values for 

margins and alignment in the appropriate fields.  
 Set scale in the Scale field.  
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 Choose Fit to paper to scale the print area as large as possible for the specified paper 
size.  

 To specify an exact scale for the print, select Scaled and type the scale (in percent) 
into the edit box.  

 Select Unscaled (1:1) to print so that 1 millimeter (or inch) on the paper will represent 
1 millimeter (or inch) on the image.  

 Specify the page margins in the Page Margins/Alignment fields.  
 To specify margins, enter their values in the Page Margins edit boxes. The upper left 

edit box contains the value of the left margin, the upper right box – the top margin, the 
lower left box – the right margin, and the lower right box – the bottom margin. Margin 
values are positive.  

 If the print output is smaller than the current paper size (one page printing), you can 
specify the print area alignment in relation to the paper margins.  

 To specify the type of alignment, press the appropriate button in the Alignment field.  
 If the print output is larger than the current paper size (multipage printing), the 

Alignment field is disabled.  
 Enter a number of copies in the Copies field and measurement units in the Units field. 

You can choose the pages to print in the Pages field.  

While setting up the print parameters you can use the on-screen print preview feature to 
observe how the print is positioned on the paper. The figure below shows an example of the 
on-screen preview for one-page printing. The outer frame shows the paper boundaries. 
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For multipage printing, the program splits the print out-put onto several parts. In this case the 
figure below shows how the on-screen preview may look. 

In this case the four frames represent the four pages. They show the pages with/without the 
specified page margins. 

 If your image size exceeds the current paper size you may select one of the following 
options: Fit to Paper, Crop by Paper or Cut to Pages.  

 The Enable Rotating option allows your image to be fit within paper width and to 
optimize nesting of smaller images.  

 In case you select the Print Image Border option, RenderEM will print a dash-dot line 
of your image border. Further it may help you cut the sheet into individual images.  

 Press OK.  

After the printing and nesting options are set you should save them to the template file for 
future use in batch printing.  

If the Nesting option is set to on, RenderEM will display the Nesting… dialog box after plotting 
a first image. You can visually control the nesting and filling procedures with the capability of 
interrupting and printing the current sheet content before the sheet is filled up. 

Image Stitching: 
 

Image stitching is the process to stitch 2 images or more (generally maps), projected 
identically on the XY plane and having common reference sections. 

 
In RenderEM, the functionality of 2-dimensional stitching has been incorporated with a view 
to consolidate 2 or more sections (snaps or image) of an object (Designs or maps) into one 
extended image. 

 
In order to perform image stitching, open the host image (the image on which the section 

image needs to be stitched) and the click on Tools>Image Stitching Ribbon Button  . 
 

As soon as the Image Stitching button is clicked, the image canvas gets bifurcated into two 
panels placed side by side. The left hand side panel is our old image canvas which contains 
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the host image and the second panel is supposed to contain the section image that needs to 
be stitched with the first (host) image.  

 
The right panel contains a preview canvas and a set of buttons placed at the bottom.  

In order to open the second image, click on the File Open button . This would open a File 
Open Dialog Box from where the user can select the section image as shown below: 

Now click on the ‘Reference Points’ button  to select reference points on both the images. 
This will open two crosses (one Red and the other Blue and encircled in the manual for clarity) 
on both the images as shown in the figure below: 

Now the user needs to choose two reference points on both the images that conforms to the 
same location (common location) on either of the images and place the crosses on those 
points by simple click and drag. Ensure the red crosses on both the images should be placed 
on the same precise location on either of the images and so should be the same for the blue 
crosses. Placing the red cross on point A (suppose) in Host image and placing the blue cross 
on the same point A’ (on the section image) and vice versa would yield erroneous results.   
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Once the points are placed precisely (Tip: in order to place the crosses with precision zoom 

in the images to an appreciable extent before placing), click on the Preview Button . This 
will super-impose the two images on the parent (Left-hand side) canvas as shown: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Use the Layer buttons  to place one image above the other or vice versa before final 

rendering. One done, click on the  button so that we get the final output as depicted below: 
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38 
 

RenderEM User Guide 

Chapter 4 – COLOR FILTERS AND TOOLS 
 

Brightness/Contrast 
Brightness sets relative color lightness or darkness. It is usually measured as a percentage 
ranging from 0% (black) to 100% (white). 

Modifying contrast enables you to increase or reduce the image brightness range. An image 
with the same brightness value has zero contrast value. If the contrast value increases, it 
causes an increase of the brightness range, i.e. darkening dark colors and lightening light 
ones. Image contrast is measured in percent ranging from 0% (pure gray) to 100%. Color hue 
usually means a color, and saturation means color purity. You have the ability to completely 
modify an image color. 

Hue is a light wavelength reflected from or transmitted through an object. Usually hue is 
identified by the name of a color, such as red, orange, or green. Each hue has a specific 
position in the standard color wheel and is characterized by a specific angle between -180° 
and +180°. 

Saturation is the degree of color purity. Saturation defines the ratio of gray and the specific 
hue and is measured as a percentage from 0 percent (gray) to 100 percent (fully saturated). 

To modify image brightness, contrast, hue and saturation 
 Click the button on the Color toolbar or choose Brightness/Contrast from the Color 

menu. The following dialog box is dis played: 

 
 Use the appropriate boxes or sliders to modify the value of the following parameters: 

Brightness, Contrast, Hue, and Saturation. 
 The preview window displays the effect of modifying the parameters. You can zoom in 

and out and show actual image pixels (pressing “1:1” button). You can also switch the 
preview pane off.  

 Click Apply to run the operation. 

Equalize 
This operation is used for precise adjustment of image brightness, hue, and contrast. The 
algorithm of correction by histogram requires two threshold brightness levels to be specified – 
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the brightest and darkest pixels, and image gamma that defines the position of the middle 
bright-ness value relative to the current threshold values. 

The gamma defines a ratio of the brightness range length between the average and the 
brightest value to the length of brightness range be-tween the dark threshold and the average 
value. As a result, the pixels with a brightness value below the dark threshold gain a brightness 
value of zero; the pixels with a brightness value above the brightest one gain the maximum 
brightness value (255), and the brightness values of the pixels in between are relocated evenly 
in conformance with their range lengths determined by the image gamma. 

The increase of gamma value causes the range for brightness value in the dark range to 
reduce, and therefore it increases the contrast, at the same time reducing the contrast in the 
light hue area, and vice versa. 

The command enables you to redistribute both image pixels average brightness and 
brightness by separate color pixel components (Red, Green, and Blue). It enables you to 
correct image pixel color, for example, to turn a pink background to pure white. 

To correct an image by histogram 

Click on the Color Equalizer button from the Color menu. The following dialog box appears: 

 This dialog box represents the image histogram, displaying the average number of 
pixels corresponding to each brightness value. The left part of the histogram 
corresponds to low brightness value, and the right one corresponds to high brightness 
value (the lightest tones). The sliders in the bottom part of the histogram indicate 
threshold values: the left one is for the darkest value, the middle one is for the middle 
value, and the right one is for the brightest pixel. 

 The Levels box provides the numerical expression of the current threshold values. You 
can select one of the four histograms: Master displays summary pixel brightness 
distribution, Red, Green, and Blue displays distribution of the corresponding pixels 
color components. Using the Master histogram slides, you can proportionally modify 
the threshold value for all components at once. The Red, Green, and Blue histogram 
sliders modify brightness threshold values separately for the corresponding color 
component. 
 

 The eyedroppers are used to select threshold values and gamma for an image. If you 
select a color sample with the eye-dropper, it defines the threshold value for the 
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darkest (or the lightest) for all components equal to the corresponding components 
values of the selected color. If you select a color sample with the   eye-dropper, it 
defines the position of the middle tone, and hence defines the image gamma. 

 Select a histogram corresponding to the color component to be corrected.  
 Specify the brightness value for the darkest and the brightest pixels, and for the image 

gamma. Use Levels or eyedroppers to do this. Use the histogram sliders for precise 
adjustment.  

 The preview window displays part of the image. Using the preview management tools, 
you can adjust optimal correction parameters.  

 Using the Auto button you can automatically specify the light and dark threshold values 
so that the brightness values of each color component not found in the image are cut 
off. In this way automatic correction tries to increase the image contrast as much as 
possible, slightly modifying brightness values.  

 Suppose you want to make the background tone of a map image pure white. To do so, 
you should select a background sample with the white eyedropper. The white triangle 
in the Master histogram moves to the position corresponding to the selected color 
brightness. All the pixels with a brightness value above the defined one become white. 
Then suppose you want to turn outlines, which are not pure black after scanning, to 
black. If you select a color outline sample with the black eyedropper, all pixels with 
brightness value below the defined one become black.  

 The brightness value of the remaining pixels will be proportionally redistributed within 
the new tone range. As a result, the image contrast increases. By moving the gray 
slider (modifying gamma value) you can redistribute the contrast between the light and 
dark image parts.  

 Click Apply to run the operation.  

You can apply this operation several times, consistently modifying an image pixel brightness 
distribution. 

Binarization and Color Separation 
Binarization and Color Separation are the procedures that extract areas of the same color (or 
falling within the specified color range) to a separate monochrome layer. 

Binarization creates monochrome raster images, containing a black-and-white representation 
of color objects. For example, from one image of a scanned map you can extract and place to 
separate monochrome layers objects of different colors: roads, rivers, and other objects. This 
method provides you with the means to place objects that have one or several different colors 
on the original image, to a separate monochrome layer. 

With Color Separation you can convert a color image to a set of mono-chrome raster layers. 
This method guarantees that the black-and-white (or monochrome) representation of each 
pixel of the original image will be placed on a certain layer. 
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Binarization Basics  
Binarization creates a new monochrome image of a specified color, which is placed on a 
specified layer. Using specific criterion the program defines which pixels of the original (color 
or gray-scale) image should become black (foreground pixels), and which ones should 
become white (background pixels), and then generates a monochrome image and places it 
on a new raster layer. The criterion for division of pixels into two sets is defined by the selected 
binarization method and its parameters (threshold values or a color range), specified in the 
Binarization dialog box. 

To binarize an image 
 Click the button on the Color toolbar or choose Binarization from the Color menu.  
 In the dialog window select a method and adjust its parameters. 
 Click Apply. 

Binarization applies various conversion algorithms, which are called binarization methods. The 
chosen conversion method should be appropriate to the image type. 

Threshold by Gray 
Threshold by Gray converts color pixels with brightness values above the specified level to 
background dots, and pixels below this level to image dots. 

This method may be used for converting both color and gray-scale images. When converting 
a gray-scale image, RenderEM uses its gray levels. When converting a color image, the gray 
levels are defined by the brightness value of color dots. 

Threshold by RGB 
When using Threshold by RGB, you should define three threshold levels for the Red, Green, 
and Blue components. RenderEM converts color dots with Red, Green and Blue values below 
the appropriate threshold levels to black dots (image dots). 

Binarization Dialog Box

To open the Binarization dialog box
Choose Binarization from the Color Tab. 

 

The controls and buttons described below are the same as the Threshold tab of the 
Binarization dialog box. 
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Channel 
You can choose a color information channel type from this list. The term color information 
channels stands for the information on the color components of image pixels by a certain color 
representation model. 

The number of available channels depends on the image type. Every color image has five 
channels: Red, Green, Blue, Hue and Gray. For gray-scale images only the Gray channel is 
used. 

Depending on the selected binarization method, either one or three tri-angular sliders may 
appear in the bottom part of the histogram. These sliders allow you to adjust parameters of 
the current binarization method, i.e. to specify range parameters and a threshold level. 

Layer 
This allows you to specify the name and color of the layer, on which a monochrome image will 
be placed after binarization. 

Apply 
Starts the binarization procedure. 

Color Separation Procedure 
This procedure is used to separate color image dots in non-overlapping sets. The objects of 
one sort are usually marked with the same color; therefore we are able to separate image 
objects using their color proper-ties.

The first step of specifying separation parameters is to define a set of object categories in the 
original image. Each category is based on a set of basic colors. The dots that have these 
colors or colors close to these, fall in the same category (at least one basic color for each 
category must be specified). For example, a category set may be the following: back-ground, 
isolines, roads, railways, buildings, vegetation, rivers, etc. You can specify up to 255 
categories. Each category has two properties: name and symbolic color.

A symbolic color is used to display dots, belonging to a certain category. This color is shown 
in the preview window during the adjustment of separation parameters. It is also assigned to 
the monochrome layer to which the dots of this category are transferred. A symbolic color 
does not need to correlate with the color of extracted objects.

On layering, the program places the dots of each category in a separate monochrome image. 
The program assigns the specified new color to all dots belonging to the same category. The 
original color image is left unchanged on its own layer. 

To perform Color Separation 

 Click the  button on the Color tab. 
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 Create a category set, using the Create Category button.  If you want to modify a 

category definition or delete a category created by mistake use the Delete or 

Modify buttons . Use the preview tools to view the effects of changing the 
parameters. Note that an image preview at a scale of 1:1 provides the most reliable 
results. 

 If you are not satisfied with the separation results, modify the basic colors in each 
category. Note that you should specify a sufficient number of base colors, describing 
each category. You should select color samples both from the middle and the 
boundary of the object. 

When you are satisfied with the quality of separation, click the Apply button. 

Tuning Color Separation 
 
Category attributes and basic colors are specified in the Color Separation dialog box. The 
Categories section contains a list of specified categories, and buttons that allow you to create, 
modify, and delete category definitions. The Colors section displays a list of the basic colors 
within a category and buttons that allow you to add or delete the basic colors of a selected 
category. 

To add a new category 

 Click the   - Create category button in Categories.  
 Specify with the eyedropper tool the object in the image, the dots of which should fall 

within the new category.  
 The Layer Name and Color dialog box will be displayed.  
 Here you can specify the name & symbolic color for the category.  
 Click OK. 

In the Categories list a new category appears, and in the Colors list the color selected from 
the image is shown. If you make a mistake when specifying a category, delete its definition or 
modify its symbolic color and name. 

To delete a category definition
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 Select a category from the list of Categories. 

 Click Delete.  

To modify the name and symbolic color of a category
 Select a category from the list of Categories. 

 Click the Edit Category button. 

The Layer Name and Color dialog box will be displayed. Enter a new category name in Name 
and/or select a symbolic color from the palette. Click OK. Note that when a category definition 
is modified, its set of basic colors does not change. 

To add a basic color to a category
Select the required category from the Categories list.  

 The current set of basic colors for the selected category will appear in Colors.  

 Click the eyedropper  button in Colors and specify a point on the image.  

The selected color will be added to Colors.

If you make a mistake when selecting a basic color, it can be deleted. A mistake in color 
selection is detected by examining the separation results shown in the preview window.

 

To delete a basic color from a category
 Select the required category from the list of Categories.  
 Select the required base color from the list of Colors.  

Click Delete.  

Color Reduction 
This procedure is similar to that of color separation, described in the previous section. The 
only difference is that you do not have to specify categories names, since color reduction does 
not cause the creation of additional layers. 

To open the Color Reduction dialog box 

Click the   button on the Color toolbar or choose Color Reduction from the Color tab. 
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This procedure is performed in the same way as the color separation procedure. The functions 
of this dialog box are the same as those of the

Color Separation dialog box. 

Blur

This filter produces a blur effect on the image, giving the impression that it is slightly “out of 
focus”. Blur filtration reduces image clearness, but makes image areas with texture fills more 
even. This procedure can have a positive effect on further binarization or image color 
separation.

To calculate pixel color the program replaces its color value by the averaged value of the area. 
Area pixels color characteristics AS are considered with weight function; two-dimensional 
Gaussian distribution with the center located in the current pixel is used for this purpose.

Radius is the only filter parameter. The increase of its value produces a stronger blur effect.

To blur an image

 Click the  Ribbon Button on the Color tab  
 The following dialog box is displayed:  

 Type values from 1 to 10.0 in the Radius box to specify the blur level. The increase of 
its value produces stronger blur effect.  

 Choose Apply to run filtration.  
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 Blurring with a large Radius coarsens the image and removes details. The blur effect 
is reduced as the Radius setting is reduced. For more control when using the blur filter, 
you should run the filter several times with a small Radius value, using the Apply 
button.

Adaptive Blur
The Adaptive Blur command is used for intelligently “de-screening” images. This filter tries to 
keep sharpen borders be-tween different colors while smoothing similar color areas. See 
pictures below (Original, Blur, Adaptive Blur): 

 

To adaptively blur an image

Choose Adaptive Blur Ribbon Button  from the Color Tab.

In the Adaptive Blur dialog box type values from 1 to 10.0 in the Radius box to specify the blur 

level or use the slider.  

Type values from 0 to 255 in the Threshold box to specify the threshold level below which the 
blurring is going to take place for individual pixels in the image. You may also use the slider 
for the same. 

Observe the effect of the command in the Preview window.  

Choose Apply to process the image. 

Unsharp Mask

This filter seeks color transition boundaries in the image and improves their sharpness.
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The filter modifies pixel contrast on color transition boundaries, producing an overall increase 
in image sharpness. This filter can be used for correction of images that became blurred after 
interpolation, for example, after such operations as scale, resolution modification or 
calibration.

To increase outline sharpness

Click the   Ribbon button on the Color Tab  

The following dialog box is displayed: 

 Enter a value in the Threshold (Sensitivity) box or use the appropriate slider to specify 
the desired effect of the filter application from 0 to 255. The effect of the filter application 
becomes stronger as this value is increased.  

 Enter the Radius value.  
 The higher the Radius value you specify, the more pixels surrounding the color 

transition boundary will be processed. Low radius values only increase the sharpness 
on the boundaries.  

 Viewing the results in the preview window should allow you achieve the optimum 
parameter value for the entire image.  

 Choose Apply to process the image. 

Gamma Correction

This tool is used to enhance the overall quality of an image by changing its so-called “color 
profile” - i.e. it applies an algorithm that changes the distribution of brightness.

Every image has a brightest point (“white” point) and a darkest point (“black” point). The points 
that have intermediate values of color intensity are usually distributed unevenly, forming a 
curve of arbitrary shape. Gamma value defines the slope of the curve halfway between black 
and white. Using the Gamma Correction tool you can make points that fall in the specified 
range of brightness brighter or darker. You can also influence the brightness of Red, Blue or 
Green colors.
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To change color profile

Click the   Ribbon Button on the Color toolbar or choose Gamma Correction from the 
Color menu.  

The following dialog box is displayed:  

 Choose the Master Gamma Slider or the individual color gamma Sliders (Red, Green 
or blue) to automatically adjust the color of the image. Please note, the Master Gamma 
remains active only when the Red, Green and Blue gamma value levels are exactly 
the same. 

 Observe the changes in the preview window. 
 Click on the Apply button to process the image.     
 You may reset the value of the individual gamma to make the Master Gamma Slider 

active. 

Color Filter  

Click on the downward facing arrow of the  Color Filters Ribbon gallery item and choose 
any of the below mentioned options: 

 
Click on the Red Filter to pass only the Red component of the image. 

 
Click on the Green Filter to pass only the Green component of the image. 

 
Click on the Blue Filter to pass only the Blue component of the image. 

 
Click on the Gray Filter to convert the image into Gray-scale. 

 
Click on the Filter to Binarize the image. 

 
Click on the Cyan Filter to filter off the Red component from the image. 

 
Click on the Red Filter to filter off the Green component from the image. 
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Click on the Red Filter to filter off the Blue component from the image. 

 
Click on the Filter to give the image a Sepia look. 

 
Click on the Filter to give the image a Contemporary look. 

 

Inversion 

Inversion converts an image to its complementary counterpart. Click on  to convert an 
image to its inverted (negative) form.  

Hue Saturation and Luminosity 
 

Hue, Saturation and Luminosity are the three parameters that define the cylindrical co-ordinate 
representation of a color space in RGB model. 

 
Hue determines the color of an individual pixel in a 360 degree color wheel. 
Saturation defines the concentration (richness) of color in the color space and ranges from -
100 to +100. 
Luminosity determines the level of brightness (lightness) of the color pixels and the value 
ranges from -100 to +100 in RenderEM. 

 
In order to change the HSL/HSV of a color image in RenderEM, click on Hue Saturation Ribbon 

Button  on the Color Ribbon Tab. This would open the Hue Saturation Luminosity dialog 
box. 

 

 
 

Change the level of any of the three parameters using the sliders as shown. The Preview 
window will show the desired changes. Once completed, click on the Apply Button. 

 
Drawing on a Raster Image 
RasterID has special drawing tools that enable you to make minor changes to the graphics 
AS on a raster image. These tools are applicable to both monochrome and color images. 

Choose the Paint command from the Tools Tab. The buttons and controls of the Paint toolbar: 

Using the Font Attribute dialog you should specify the text parameters for entering text. This 
dialog is displayed automatically after selecting the text tool. 
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Using the Stroke Width dialog you should specify the line width for drawing. This dialog is 
displayed automatically after selecting the drawing tools. 

 

 
To draw an arbitrary line with the pencil tool: 

 Specify the line width. 
 Press the mouse button (left or right – see below), specify the first 

endpoint and keep it pressed while drawing a line; release the 
button at the other endpoint of the line. Using the left mouse button 
causes your line to be drawn with the foreground color, while the 
right mouse button produces the background color.

 

 

 
Erasing with the White background  
 

 

 
To flood-fill with the current foreground or background color: 
You should specify a closed area to flood-fill. To select colors on the 
image: 
Specify a point with the required color on the image. 
Press the left mouse button to select the foreground color; or the right 
mouse button – to select the background color.  


 
Drawing a line by two points 

 
Drawing an arc by two points. 

 
Drawing a rectangle by two points. 

 
Drawing a rectangle with the foreground color flood-fill.

 
Drawing a circle by two points.

 
Drawing a circle with the foreground color flood-fill.

 
The orthogonal mode.

 

 
To enter a text:

 Press this button and set the text parameters in the displayed Fonts 
dialog; 

 Specify the text position on the image – an insertion point and a 
rotation angle with the mouse button pressed. 

 Type a text from the keyboard. 
 Press Enter. 

 

 
Setting the line width on the image.
 
Press this button and specify a point with desired size on the image with 
the mouse button pressed; then RasterID will be drawing with the size you 
have specified. 
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Selected color is displayed in the select color square. 

 

 
The Color palette for 
selection.

To select a foreground color 
you should pick a required 
color and press the left 
mouse button.
To select a background color 
you should pick a required 
color and press the right 
mouse button.
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Chapter 5 – SCRIPT STUDIO AND BATCH PROCESSING
 
Batch image processing makes it possible to apply a sequence of operations to a number of 
images unattended. RasterID can automatically process a group of images and then re-save 
them to the same file or to separate files. All you have to do is create a batch job and then run 
it. 

Batch Processing

To create a processing scenario (script file)

A Processing scenario is a sequence of operations for each image (for example, to increase 
the image quality). Before running batch processing or indexing you have to create one or 
more processing scenarios and save them to a script file. RasterID script files have the 
extension “.TPL”. To create a draft of the processing scenario you have to check the image 
quality visually. To do so you should load a selection of images and look at each of them. Try 
to estimate the image orientation, flip, contents and title blocks contained in them. Keep the 
required processing actions in your mind. The recommended sequence of operations is as 
follows:

 If all images have incorrect orientation or flip you should include the  
 Rotate or Mirror command in the processing scenario.  
 If images are negative, include Inversion command.  
 The images contain a lot of vertical and horizontal lines (for example, in the case of 

mechanical and architectural drawings). If these lines are not parallel to the image 
margins, the Auto Deskew command should be applied.  

 If the images have linear distortions and contain a bounding frame, you may include 
the Four Point Correction command. RasterID will try to find the frame and the closest 
paper size for it and will correct these distortions.  

 If the images are “dirty” (meaning they contain a lot of small spots and holes), you 
should use the Speckle Remover and/or Smoothing commands. If you cannot estimate 
the speckle size yourself, RasterID will do it for you, just turn on the Auto-Estimate flag 
parameter.  

Note If the image does not contain small speckles, Speckle Remover may delete texts, 
dashes or any small symbols from the image when Auto-Estimating mode is turned on. In this 
case it is better to use your own specified speckle size setting.

To change the image size, include the Crop by Frame command if the image contains a 
bounding frame, if it does not contain one use the Crop by Black command  

To print the processed image, include the Print command in the processing scenario.  
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To create the processing scenario and save it to a script file click on the Script Studio Ribbon 

Button  from the Tools Tab.

The left part of the dialog box contains the sorted list of commands that you can use in your 
processing scenario. The right part of the dialog box represents the Script window. It contains 
the sequence of required commands for each image and shows the contents of your 
processing scenario. Error messages are output in the lower-right field.

 

To add a required command to the processing scenario select this command item from the 
left part and move it to the Script window using standard mouse-dragging techniques. 
Alternatively you can click the   button to include a command in the script.  

If the selected command contains parameters, you can specify its values. To do so click on 
the required command item in the right part and you will see the parameters list for this 
command. Click on the parameter item and specify its value. If you do not specified parameter 
values, RasterID uses default values.  

Repeat these operations for each command of your processing scenario.  

To change the order of commands you can use the buttons   or . 

To remove a command item from the processing scenario you should select it and click the 

delete button  .  

Click the Save or Save As button to store the processing scenario to the named script file for 
use during batch processing.  

To edit an existing script file click Load and select the required file name from the files list.  

To apply the processing scenario to the currently loaded image click Run. This enables you to 
check the results of running the processing scenario for a selection of typical images prior to 
batch processing a complete group.  
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Edit the script using the following buttons and controls:

Butto
n 

Parameter Description 

 

 

 
Opens the required 
file through the 
Browse Window 
and saves the path 
in the Textbox as 
shown 
 

 

 

 
Closes the File. By 
default, the 
checkbox remains 
unchecked, which 
means the 
processed file is 
saved in its original 
location before 
closing. If the user 
does not intend to 
replace the original 
file, keep the ‘Do 
not Save Image’ 
checkbox checked. 
 

 

 
No parameters Required 
 

 
Saves the altered 
file at its original 
location. 
 

 

 

 
Saves the altered 
file in a new 
location/with a new 
name, keeping the 
original file 
untouched. 
  

 

 

 
Loads the print 
template from the 
location as 
specified by the 
user and print 
accordingly. 
 

 

 
No parameters Required 
 

 
Inverts the image. 

 

 
No parameters Required 
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 Only allows the red 
component of the 
image to pass. All 
other components 
are reduced to 
zero. 
 

 

 
No parameters Required 
 

 
Only allows the 
green component 
of the image to 
pass. All other 
components are 
reduced to zero 

 

 
No parameters Required 
 

 
Only allows the 
blue component of 
the image to pass. 
All other 
components are 
reduced to zero 

 

 
No parameters Required 
 

 
Gives a sepia look 
to the image 

 

 
No parameters Required 
 

Crops the image on 
all sides till the first 
occurrence of a no-
white pixel. 

 

 

Crops a rectangular 
area within an 
image whose co-
ordinate is 
represented by the 
top, left, right and 
bottom margins. 
The margin values 
are specified in 
1/96th of an inch 
unit. 

 

 
No parameters Required 
 

Tries to crops an 
image in lines with 
its frame. 

 

 
No parameters Required 
 

Tries to Deskew an 
image (preferably 
an engineering 
draft or design) with 
lots of horizontal 
and vertical lines. 

 
 
No parameters Required 
 

Flips an image 
through its Y-Axis. 

 
 
No parameters Required 
 

Flips an image 
through its X-Axis. 
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No parameters Required 
 

Rotates an image 
clockwise through 
90° 

 
 
No parameters Required 
 

Rotates an image 
counter clockwise 
through 90° 

 

 
No parameters Required 
 

Rotates an image 
through 180° 

 
 

Rotates an image 
by a custom angle 
(range 0 to 360°) 

 

 

It smoothens out a 
binary image. The 
Medianing Radius 
value ranges from 1 
to 10 and the 
threshold value 
from 0 to 255. 

 

 

Thickens a binary 
image. The 
direction of 
thickening can be 
specified through 
the drop-down list 
and the number of 
passes can be 
specified through 
the spin-box. 

 

 

Thins a binary 
image. Either 
specify the number 
of passes or thin 
the image up to its 
skeleton. 

 
 

Removes speckles 
of size less than or 
equal to the size as 
specified in Speckle 
Size Spin box. 

 

 

 
Changes the 
Brightness/Contras
t of an image. The 
Brightness or 
Contrast value 
ranges from -100 to 
+100. 
 



 
 

57 
 

RenderEM User Guide 

 

 

Changes the Hue, 
Saturation and 
Luminosity 
(Brightness) of an 
image. The Hue 
ranges from -180 to 
+180°, Saturation & 
Luminosity from -
100 to +100. 

 
 
No parameters Required 
 

Converts a colored 
image to binary 
image. 

 

 

It smoothens out a 
colored image 
selectively 
depending on the 
threshold value. 
The Medianing 
Radius value 
ranges from 1 to 10 
and the threshold 
value from 0 to 255. 

 

 

It blurs a colored 
image. The 
Medianing Radius 
value ranges from 1 
to 10.  

 
 

Applies color 
reduction 
depending on the 
pre-assigned 
Template value. 

 

 
No parameters Required 
 

Converts a colored 
image to Gray-
scale. 

 

 

Launches the 
automatic Equalizer 
procedure by 
loading a 
predefined 
equalizer Template. 

 

 

Applies Gamma 
Correction to a 
colored image. The 
value of the 
individual color 
Gammas can be 
specified. 

 

 

It sharpens a 
colored image. The 
Medianing Radius 
value ranges from 1 
to 10 and the 
threshold/sensitivit
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y value from 0 to 
255. 
 

 

 

Sets a rectangular 
work area within an 
image whose co-
ordinate is 
represented by the 
top, left, right, and 
bottom margins. 
The margin values 
are specified in 
1/96th of an inch 
unit. 

 
No parameters Required Resets the work 

area previously set. 

 

 

Recognizes a Title 
Block information. It 
requires a Title 
Block Template file 
and an output 
Template which 
has information on 
the output database 
and its’ set-up i.e. 
how the data is 
supposed to be 
organized. 

 
To Create Batch Job 

A Batch job is a sequence of operations for a group of images. To create a batch job you 
should specify the input images or set location of a folder or a set of folders to be processed, 
the script file (which contains the processing scenario), and output images. You can save 
processed images back to their original files or to new files; you can also select different file 
formats for the destination files.

 You may apply more than one processing scenario to the selected images in your 
batch job. To prepare a batch job and tune the input and output options choose Batch 
Studio from the Tools menu. The Batch Studio dialog box appears (see next page).

 The Select File or Directory tree shows existing files and folders; you can use the 
format list option to show appropriate files.  

 To specify those images to process, select the input files (or an entire folder) and move 
them to the Input files or directories section using the standard drag-and-drop 
technique.  

 Select one or more script files and place them into the Script Files list. This specifies 
the processing scenario when running a batch. If you click on a script list item, the 
Script Studio dialog (described above) opens, and you can check or edit the processing 
scenario contents.  
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 To save the images to new files you should select an output folder and file type. If you 
do not do this, the images will be saved back to the same files.  

 You may also save the processed images into a single multi-image Output file; 
depending on your choice it would be saved either as a TIFF of a PDF file.    

 Press Run to launch the batch. The input files are processed with the selected scripts 
from Script files list and the results are put into the Output folder. The error or progress 
messages are shown in the lower right section of the dialog. Press Cancel to stop the 
script execution.  

Creating Batch Job through Virtual Scanner 
Just like Batch Processing, Virtual Scanner can also process files in batches. The only 
difference between the two is whereas batch Processor allows both folders & files within its 
input list; Virtual Scanner always works up a specific folder and works with only one scripting 
file at a time. 
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 You need to specify the path that needs to be scanned for image files. 
 The script-file location and filename. 
 The target output i.e. whether you would like to save the output in a specified folder or 

let the function replace the old original or save the entire outcome in a multipage file 
(TIFF or PDF) 

 The File Processed Dialog box would show the processing in real time. 
 The stop button to stop the program in the middle of scanning. 
 Scan Interval (in Seconds) can also be specified. 

 The  button can be used in junction with the script file to edit its content. 
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Chapter 6 – MULTI-PAGE TIFF/PDF FILE SUPPORT
 
Multi-page Tiff and PDF support: 
RenderEM supports viewing, navigating editing and saving of multi-page tiff files and Portable 
Document Format files (as Raster PDF images). In case of PDF, however, the edited 
document cannot be saved as a PDF file; instead it needs to be saved as a multi-page Tiff file. 

 
Opening a multi-page tiff/PDF file would automatically open a side panel showing a list of 
pages in thumb-nail view (5 pages at a time) starting from the initial page along with a 
navigational panel as shown below: 
 

 
 

In order to navigate to any of the thumbnail pages, the user simply needs to click on thumbnail 
view. If the page he wishes to navigate to is not within the list of pages, the navigation buttons 
can be used to hover between any pages in the book. Alternatively, if the page number is 
known, entering the page number in the textbox provided and pressing enter will take the user 
to the desired page.  

 

 
 

The Side Pane also has a tree/list view which will list all the pages in a tree. Clicking on any 
of the nodes in the tree will also help in navigating to the desired page. 
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Multi-Page Tiff /PDF Maker 
RasterID is endowed with the functionality to create multi-page tiff/pdf file from individual 
image files (*.jpg, *.bmp, *.png, *.jpeg & *.tif) or multi-page tiff files as well.  In order to create 

a multi-page file click on the Multi-Page Tiff/PDF Maker Ribbon Button which would open 
a Multi-Page Maker Dialog Box. Click on Add button to select the desired files from Windows 
Explorer. Every time the Add button is clicked a new path gets shown in the Path List.  Once 
all the desired files are chosen, the user may wish to rearrange the page numbers by clicking 
on the Up or Down Arrow Keys. Choose the relevant option i.e. whether you want to save it 
as a tiff file or as a pdf file from the enlisted radio-buttons. Finally press ‘Save’ to save the final 
output in a desired location with a user-defined filename.     
 

      
 

Additionally you may choose to reset, close or abort the operation if required or eliminate a 
particular file from the list by selecting it and clicking on the ‘Delete’ Button. 
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Page Extraction from Multi-Page Tiff File: 
In RenderEM it is possible to extract and save a single page as a separate file from a multi-
page tiff file or a multi-page PDF file.  In order to do this the user needs to click on the ‘Save 

Current Image’ Ribbon Button . This button only gets activated when a multi-page file is 
opened in the RenderEM canvas. Otherwise, the button remains inactive. In order to save the 
desired image, the user needs to navigate and select the proper page from the multi-page 

document and click on    button to save the individual page as a separate file. 
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Chapter 7 – TITLE BLOCK RECOGNITION/INDEXING OUTPUT
 

Title Block Recognition: The Title block is a boxed area containing general information 
about the part in the drawing. The main purpose of the title block is that it contains important 
text information about the part such as company name, drawing number, part number and 
other pennant information. Different companies may have somewhat different formats for their 
title blocks, but most of the time the title block is located in the lower right corner of the drawing 
sheet. 

Indexing is a two-step process of searching and recognizing title blocks on raster images and 
transferring this recognized data to an external database, EDM-system or user defined file. 
For example, if you have MS Excel on your computer RasterID can transfer the title block 
contents to an Excel table. RasterID can find title blocks and recognize texts in the fields 
through the internal OCR engine. 

Before running indexing you have to create a title block template. If your images contain 
different types of title blocks you will have to create a unique template for each one. Every title 
block must be saved as a named template for further use when indexing. 

Creating Title Block Templates: To create a new title block  

1. Open an image file containing the title block you want to train.  
2. The image must be oriented correctly. Use The Rotate command to change the image 

orientation.  
3. Check that orthogonal lines are parallel with the image margins. If necessary apply the 

De-skew command.  
4. If the image is “dirty” you need to apply the Speckle/Hole remover.  
5. Set the zoom level so that all fields of the title block are visible on the image. 

6. Now click on Image Menu, and then on Title Block Recognition  
7. The Title Block Recognizer Window pops up as shown below. It is on this window, the 

user needs to train the title block. 
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8. Click on the  button and draw a rectangular area on the image containing the entire 
title block. A red hollow rectangle bounding the entire title block region is created. 

9. Once the Title Block area is marked, the  button gets automatically enabled. Click 
on that button every time you wish to mark a green rectangular hollow patch within the 
title block using your mouse. Each of such rectangular portions designates a 
field/column name. As soon as such a field area is marked, a field is automatically 
created and is stored in the ‘Rename Fields’ list box. You can rename a fieldname by 
selecting the field (it should appears in the text box below the list-box) and change the 
same there by clicking on the ‘set’ button.    

10. You can also deliberately hide/mask a certain area within the title block so that it does 
not appear in the recognition text. This can be accomplished by clicking on the mask 

 button and drawing a rectangular patch in the similar fashion. Only this time a solid 
red rectangle appears instead of the hollow ones. 

11. Once all the fields have been marked and named, you may save the template in a 
separate template file by clicking on Template > Save Template. Please remember, 
this template will suffice all drawings (of identical size/location) having identical Title 
Block Layout (a convention maintained by most companies). For drawings having 
different patterns in their Title Block, you’d need to create separate template files. 

12. You can instead click on OK button to recognize the current drawing and save the 
same in any of the indexed output format, provided you have already predefined and 
selected a customized schema for the indexed output format. 

13. Alternatively, you may use the template file in any of the Batch Processing utilities 
(Batch processor or Virtual Scanner) to extract the output collectively into any of the 
provisioned databases. In that case remember to scan only identically patterned 
drawings in one lot.   

Indexing Output: RasterID right now has provisions for storing Title Block data in 3 
different formats: MS-Excel, CSV Text File and MS-Access. 

Output to MS Excel:  

If you choose the MS Excel Output option in the Indexing Output dialog box, RasterID 
launches MS Excel. It loads the existing .xlsx file or creates a new table using the file name 
specified in the Setup dialog (see next page). 

In the Excel Customization box, you may choose a new or an existing file as per your 
requirement. You can append data in a specific sheet or a new sheet and choose to include 
or exclude the Title Block Image. You also have the liberty to include the column name or 
exclude the same if not required while appending data below (Existing Sheet). 

Once done setting up the Excel customization you can either save it as a template file or 
click on OK. In the latter case, the custom excel setting is stored as default throughout the 
session unless other customization options are deliberately selected.   
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Output to Text File:  

If you choose the Comma-separated Text Output option in the Indexing Output dialog box, 
you would need to check either the new or existing file check-box specified in the Setup 
dialog.  If you choose Use new file, you would need to choose the path and name of the new 
file (with a .txt extension. Alternatively, you may select an existing output file.  
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    Output to MS Access:  

If you choose MS Access Output in the Indexing Output dialog box, RasterID launches MS 
Access or uses its DAO Engine.  

 

You may either select a new or an existing database file (.mdb or .accdb). For a new file with 
.accdb extension, you may choose to encrypt the same with a password. If on the other hand 
you choose to select an existing file encrypted with a password, you may do so as well. 

Once the database file is chosen, click on ‘Check Connection’ button to check whether 
connection has been established or not. In case of a new file a blank database gets 
automatically created when you click on the same button. You now need to specify a 
new/existing table where you wish to store the data. You are also provisioned with an option 
to store the Title Block image within the database or ignore if you do not want to. 

Similar to the above two output format, you can choose to save to or load from the template 
file. 
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Output to SQL Server Database: 

You may also choose SQL Server database as the output file for your Title Block Indexing 

Output dialog box. Click on the Settings  button just besides the SQL Server radio-button 
(selected) to open the SQL Database Settings dialog box as shown below: 

 

Specify the server name in the Server Name textbox along with the ‘Authentication’ option. 
Whereas Windows Authentication requires no other parameter, the SQL Server authentication 
will prompt user for the Login-Id & the password. Once entered correctly, click on ‘Get 
Connection’ button. If the connection gets established successfully, the database section of 
the message box gets enabled. You can enter the database name and the table name (in 
case the table exists) from the respective dropdown lists. Alternatively, after selecting the 
database, you may proceed to create a separate table for entering the data by checking the 
‘Create New Table’ checkbox. 

You may also load a Template from the ‘Template’ > ‘Load’ option or save an existing SQL 
settings template through ‘Template’> Save option. 
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Output to MySQL Server Database: 

You may also choose MySQL Server database as the output file for your Title Block Indexing 

Output dialog box. Click on the Settings  button besides the MySQL Server radio-button 
(selected) to open the MySQL Database Settings dialog box as shown below: 

 

Specify the server name in the Server Name textbox along with the ‘Authentication’ option. 
Whereas Windows Authentication requires no other parameter, the MySQL authentication will 
prompt user for the Login-Id & the password. Once entered correctly, click on ‘Get Connection’ 
button. If the connection gets established successfully, the database section of the message 
box gets enabled. You can enter the database name and the table name (in case the table 
exists) from the respective dropdown lists. Alternatively, after selecting the database, you may 
proceed to create a separate table for entering the data by checking the ‘Create New Table’ 
checkbox. 

You may also load a Template from the ‘Template’ > ‘Load’ option or save an existing MySQL 
settings template through ‘Template’> Save option. 
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